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.1 REVISION HISTORY 

Date Author Description 

2016/10/21 C. Raineri Draft version 

2016/10/25 C. Raineri Added images of the board instead of topographic views. 

2016/12/27 C. Raineri Added housing prescription. 

2017/02/14 C. Raineri Changed Cloud-JAM images  
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2017/03/31 C. Raineri Added EU DoC. 

2017/04/28 C. Raineri Modified temperature range, .added transmitted power on Wi-Fi and 
operating environment. Modified DoC.  
Change revision to V2 

2017/09/09 C. Raineri Changed STMicroelectronics reference function pack 
Added configuration of Wi-Fi Access Point parameters via serial inter-
face 
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.2 CLOUD-JAM BOARD IMAGES 
 

TOP VIEW 
 

 
 
 
 

BOTTOM VIEW 
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.3 INTRODUCTION 
This data sheet provides the description of the Cloud-JAM board, the first member of the JAM family boards.  
As RushUp product, Cloud-JAM is an accelerator product and can be used from makers, developers, high 
mix low volume products and from all who want to benefit from an off the shelf industrialized board. 
In particular Cloud-JAM is the accelerator product of the STM32 ODE system. 
For details about RushUp and STM32 ODE, please visit: 
 

www.rushup.tech 
 
http://www.st.com/content/st_com/en/products/ecosystems/stm32-open-development-
environment.html 

.4 DESCRIPTION 
The Cloud-JAM board is the industrialized version of the FP-CLD-WATSON1 STM32 ODE functional 

pack. It can connect IoT node based on STM32 Nucleo to IBM Watson IoT, transmits sensor data and re-
ceive commands from Cloud application. 

Motion & environmental sensors board connected to the cloud through Wi-Fi network using SSID, 
Password and web authentication stored in the dynamic NFC. 

Inside Cloud-JAM you can find the next STM32-Nucleo elements: 

 NUCLEO-F401RE 

 X-NUCLEO-IDW01M1 

 X-NUCLEO-IKS01A2 

 X-NUCLEO-NFC01A1 
The connection and the components are the same as all the above boards connected together in a single 
functional pack as indicated by the next picture. 

 
Cloud-JAM board embeds also the debugger so it can be used also for development and debug. 
Since the board is exactly the same as the functional pack (from electrical connections point of view), one of 
the most importat features is that the firmware is plug & play and compatible between the two development 
systems. User can develop and debug on Nucleo functional pack and then download the .bin file into the 
Cloud-JAM board. 

 

X-NUCLEO-NFC01A1 

X-NUCLEO-IKS01A2 

X-NUCLEO-IDW01M1 

.bin 

http://www.rushup.te/
http://www.st.com/content/st_com/en/products/ecosystems/stm32-open-development-environment.html
http://www.st.com/content/st_com/en/products/ecosystems/stm32-open-development-environment.html
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.6 HARDWARE & COMPONENTS DETAIL 

.6.1 Embedded debugger 

Cloud-JAM incorporates the ST-LINK V2 debugger and then is capable not only to download the firm-
ware but also to debug it with the main development tools. 

The ST-LINK/V2 is an in-circuit debugger and programmer for the STM8 and STM32 microcontroller 
families. The single wire interface module (SWIM) and JTAG/serial wire debugging (SWD) interfaces are 
used to communicate with any STM8 or STM32 microcontroller located on an application board.  

STM32 applications use the USB full-speed interface to communicate with Atollic®, IAR™, Keil® or 
TASKING integrated development environments. 

Direct firmware update feature supported (DFU)  and Status LED which blinks during communication 
with the PC. 

 

.6.2 CPU 

The STM32F401RE device is based on the high-performance ARM® Cortex® -M4 32- bit RISC core 
operating at a frequency of up to 84 MHz.  

Its Cortex®-M4 core features a Floating point unit (FPU) single precision which supports all ARM single-
precision dataprocessing instructions and data types. It also implements a full set of DSP instructions and a 
memory protection unit (MPU) which enhances application security.  

The STM32F401RE incorporate high-speed embedded memories (512 Kbytes of Flash memory, 96 
Kbytes of SRAM), and an extensive range of enhanced I/Os and peripherals connected to two APB buses, 
two AHB buses and a 32-bit multi-AHB bus matrix. The device offer one 12-bit ADC, a low-power RTC, six 
general-purpose 16-bit timers including one PWM timer for motor control, two general-purpose 32-bit timers. 
It also features standard and advanced communication interfaces.  

 I2C 

 SPI  

 Full duplex I2Ss.  

 USART  

 SDIO interface  

 USB 2.0 OTG full speed interface  
Refer to for the peripherals available looking at the specific data sheet.  
The STM32F401RE operate in the –40 to +105 °C temperature range from a 1.7 (PDR OFF) to 3.6 V 

power supply.  
A comprehensive set of power-saving mode allows the design of low-power applications. 

.6.3 Sensors 

.6.3.1 iNEMO inertial module LSM6DSL 

The LSM6DSL is a system-in-package featuring a 3D digital accelerometer and a 3D digital gyroscope 
performing at 0.65 mA in high-performance mode and enabling always-on low-power features for an optimal 
motion experience for the consumer. . 

The LSM6DSL supports main OS requirements, offering real, virtual and batch sensors with 4 kbyte for 
dynamic data batching.  

ST’s family of MEMS sensor modules leverages the robust and mature manufacturing processes al-
ready used for the production of micromachined accelerometers and gyroscopes.  

The various sensing elements are manufactured using specialized micromachining processes, while the 
IC interfaces are developed using CMOS technology that allows the design of a dedicated circuit which is 
trimmed to better match the characteristics of the sensing element.  

The LSM6DSL has a full-scale acceleration range of ±2/±4/±8/±16 g and an angular rate range of 
±125/±245/±500/±1000/±2000 dps. High robustness to mechanical shock makes the LSM6DSL the preferred 
choice of system designers for the creation and manufacturing of reliable products.  

The LSM6DSL is available in a plastic land grid array (LGA) package 
Features  

 Power consumption: 0.4 mA in combo normal mode and 0.65 mA in combo high-performance mode  

 “Always-on” experience with low power consumption for both accelerometer and gyroscope  

 Smart FIFO up to 4 kbyte based on features set  

 Compliant with Android K, L, and M  
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 Hard, soft ironing for external magnetic sensor corrections  

 ±2/±4/±8/±16 g full scale 

  ±125/±245/±500/±1000/±2000 dps full scale  

 Analog supply voltage: 1.71 V to 3.6 V  

 Independent IOs supply (1.62 V)  

 Compact footprint, 2.5 mm x 3 mm x 0.83 mm  

 SPI & I2C serial interface with main processor data synchronization feature  

 Pedometer, step detector and step counter  

 Significant motion and tilt function  

 Standard interrupts: free-fall, wakeup, 6D/4D orientation, click and double-click  

 Embedded temperature sensor  

 ECOPACK®, RoHS and “Green” compliant 

 
For any specific information and for the firmware commands and procedures, please refer to the data sheet 
of the components. 

.6.3.2 High-performance eCompass module LSM303AGR 

The LSM303AGR is an ultra-low-power highperformance system-in-package featuring a 3D digital linear 
acceleration sensor and a 3D digital magnetic sensor.  

The LSM303AGR has linear acceleration full scales of ±2g/±4g/±8g/16g and a magnetic field dynamic 
range of ±50 gauss.  

The LSM303AGR includes an I2C serial bus interface that supports standard, fast mode, fast mode 
plus, and high-speed (100 kHz, 400 kHz, 1 MHz, and 3.4 MHz) and an SPI serial standard interface.  

The system can be configured to generate an interrupt signal for free-fall, motion detection and magnet-
ic field detection.  

The magnetic and accelerometer blocks can be enabled or put into power-down mode separately. The 
LSM303AGR is available in a plastic land grid array package (LGA) and is guaranteed to operate over an ex-
tended temperature range from -40 °C to +85 °C. 

 
Features  

 3 magnetic field channels and 3 acceleration channels  

 ±50 gauss magnetic dynamic range  

 ±2/±4/±8/16 g selectable acceleration full scales 

 16-bit data output  

 SPI / I2C serial interfaces 

 Analog supply voltage 1.71 V to 3.6 V  

 Selectable power mode/resolution for accelerometer and magnetometer  

 Single measurement mode for magnetometer  

 Programmable interrupt generators for freefall, motion detection and magnetic field detection  

 Embedded self-test  

 Embedded temperature sensor  

 Embedded FIFO  

 ECOPACK®, RoHS and “Green” compliant 
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Block diagram 

 

 
For any specific information and for the firmware commands and procedures, please refer to the data sheet 
of the components. 

.6.3.3 Humidity and temperature 

The HTS221 is an ultra-compact sensor for relative humidity and temperature. It includes a sensing el-
ement and a mixed signal ASIC to provide the measurement information through digital serial interfaces. 

The sensing element consists of a polymer dielectric planar capacitor structure capable of detecting rel-
ative humidity variations and is manufactured using a dedicated ST process.  

The HTS221 is available in a small top-holed cap land grid array (HLGA) package guaranteed to oper-
ate over a temperature range from -40 °C to +120 °C. 

 
Features  

 0 to 100% relative humidity range  

 Supply voltage: 1.7 to 3.6 V 

 Low power consumption: 2 μA @ 1 Hz ODR  

 Selectable ODR from 1 Hz to 12.5 Hz  

 High rH sensitivity: 0.004% rH/LSB  

 Humidity accuracy: ± 3.5% rH, 20 to +80% rH  

 Temperature accuracy: ± 0.5 °C,15 to +40 °C  

 Embedded 16-bit ADC  

 16-bit humidity and temperature output data  

 SPI and I²C interfaces  

 Factory calibrated  

 Tiny 2 x 2 x 0.9 mm package  

 ECOPACK® compliant 
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Block diagram 
 

 
For any specific information and for the firmware commands and procedures, please refer to the data sheet 
of the components. 

.6.3.4 Barometer 

The LPS22HB is an ultra-compact piezo resistive absolute pressure sensor which functions as a digital 
output barometer. The device comprises a sensing element and an IC interface which communicates 
through I2C or SPI from the sensing element to the application.  

The sensing element, which detects absolute pressure, consists of a suspended membrane manufac-
tured using a dedicated process developed by ST.  

The LPS22HB is available in a full-mold, holed LGA package (HLGA). It is guaranteed to operate over a 
temperature range extending from -40 °C to +85 °C. The package is holed to allow external pressure to 
reach the sensing element. 
Features  

 260 to 1260 hPa absolute pressure range  

 Current consumption down to 3 µA  

 High overpressure capability: 20x full-scale  

 Embedded temperature compensation  

 24-bit pressure data output • 16-bit temperature data output  

 ODR from 1 Hz to 75 Hz  

 SPI and I²C interfaces  

 Embedded FIFO  

 Interrupt functions: Data Ready, FIFO flags, pressure thresholds  

 Supply voltage: 1.7 to 3.6 V  

 High shock survivability: 22,000 g  

 Small and thin package • ECOPACK® lead-free compliant 
Block diagram 

 

 
For any specific information and for the firmware commands and procedures, please refer to the data sheet 
of the components. 

.6.4 NFC memory 

The M24SR64-Y device is a dynamic NFC/RFID tag that can be accessed either from the I2C or the RF 
interface. The RF and I2C host can read or write to the same memory, that is why only one host can com-
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municate at a time with the M24SR64-Y. The management of the interface selection is controlled by the 
M24SR64-Y device itself. The RF interface is based on the ISO/IEC 14443 Type A standard. The M24SR64-
Y is compatible with the NFC Forum Type 4 Tag specifications and supports all corresponding commands. 
The I2C interface uses a two-wire serial interface consisting of a bidirectional data line and a clock line. The 
devices carry a built-in 4-bit device type identifier code in accordance with the I²C bus definition. The device 
behaves as a slave in the I2C protocol. 

I2C mode  
M24SR64-Y is powered by VCC. The I2C interface is connected to the M24SR64-Y. The I2C host can 

communicate with the M24SR64-Y device. 1.1.2  
Tag mode  
The M24SR64-Y is supplied by the RF field and can communicate with an RF host (RFID reader or an 

NFC phone). The User memory can only be accessed by the RF commands.  
Dual interface mode  
Both interfaces, RF and I2C, are connected to the M24SR64-Y and both RF or I2C host can communi-

cate with the M24SR64-Y device. The power supply and the access management are carried out by the 
M24SR64-Y itself. For further details, please refer to the token mechanism described inside the data sheet of 
the component. 

 Contactless interface  

 NFC Forum Type 4 Tag  

 ISO/IEC 14443 Type A  

 106 Kbps data rate  

 Internal tuning capacitance: 25 pF Memory  

 8-Kbyte (64-kbit) EEPROM  

 Support of NDEF data structure  

 Data retention: 200 years  

 Write cycle endurance:  
 1 million Write cycles at 25 °C  
 600k Write cycles at 85 °C  
 500k Write cycles at 105 °C  

 Read up to 246 bytes in a single command  

 Write up to 246 bytes in a single command  

 7 bytes unique identifier (UID)  

 128 bits passwords protection 
For any specific information and for the firmware commands and procedures, please refer to the data sheet 
of the components. 

.6.5 Wi-Fi module SPWF01SA 

The SPWF01SA intelligent Wi-Fi module represent a plug-and-play and standalone 802.11 b/g/n solu-
tion for easy integration of wireless Internet connectivity features into existing or new products.  

Configured around a single-chip 802.11 transceiver with integrated PA and comprehensive power man-
agement subsystem, and an STM32 microcontroller with an extensive GPIO suite, the modules also incorpo-
rate timing clocks and voltage regulators.  

The SPWF01SA.11 orderable parts integrate 1.5 MB of Flash and is available with an embedded micro 
2.45 GHz highly-efficient ISM band antenna.  

With low power consumption and ultra-compact (2.7 x 1.5 cm) footprint, the module is ideal for fixed and 
mobile wireless applications, as well as challenging battery-operated applications.  

The SPWF01SA parts is released with an integrated full featured TCP/IP protocol stack with added web 
server and additional application service capabilities, such as REST API for accessing files on servers in the 
cloud and support for dynamic web pages with CGI/SSI functions to easily interact with the module and the 
host processor over the air.  

For secure end-to-end communication with the cloud, an SSL/TLS stack is embedded in every module 
with no licensing charge. See application note AN4683 for details.  

The SW package also includes an AT command layer interface for user-friendly access to the stack 
functionalities via the UART serial port. For details, see user manual UM1695.  

It is always possible to upgrade the module firmware via UART and Over The Air (FOTA). Out of the 1 
MB extended Flash available on the SPWF01Sx.1y module, 512 KB of the Flash is dedicated to FW upgrade 
and the other 512 KB is dedicated to host proprietary files, organized in a file system image, accessible 
through the integrated web server.. ST recommends that users regularly check for documentation and the 
current FW version available at www.st.com/wifimodules. 
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This section provides some information regarding the SPWF01SA Serial-to-Wi-Fi b/g/n intelligent mod-
ule (order code: SPWF01SA.11). More detailed information can be found at the www.st.com web site.  

The main features of the SPWF01SA module are:  

 2.4 GHz IEEE 802.11 b/g/n transceiver  

 STM32 ARM Cortex-M3, with 64 KB RAM and 512KB Flash memory  
- 1 MByte extended FLASH for FW update  
- Over the air (FOTA)  

 Integrated TCP/IP protocol stack  

 8 Simultaneous TCP or UDP clients and 1 Socket server  

 1 TLS/SSL Socket client supporting up to TLS 1.2, including common encryption algorithms: AES 
(128,256), hash (MD5, SHA-1, SHA-256) and public key algorithms (RSA, ECC).  

 Web server supporting dynamic web pages  

 RESTful API to get & post web content  

 WEP/WPA/WPA2 personal security  

 System modes: station, IBSS, and miniAP  

 miniAP easily provisioned (SSID, PWD)  

 Industrial temperature range: -40 °C to 85 °C  

 SPWF01SA is a fully FCC/IC/CE certified module.  

.6.6 LEDs 

Cloud-JAM integrates all the LEDs presents in the Nucleo functional pack, in particular they are: 
 ST-LINK V2 bicolor LED: TLK LED 
 Power supply present: 5V LED 
 User free connected to MCU pin PA5: USR LED 
 Wi-Fi blink connected to pin 5 of the module: WLD LED 
 Wi-Fi power up connected to pin 14 of the module: WUP LED 
 Wi-Fi link connected to pin 15 of the module: WLK LED 
 iNEMO interrupt 2 connected to pin 9 of LSM6DSL: PIN LED 
 iNEMO interrupt 1 connected to pin 4 of LSM6DSL: INT LED 
 Wi-Fi TXD1 connected to pin 6 of the module: WTX LED 

 

 

.6.7 Push buttons 

Cloud-JAM integrates alla the push buttons presents in the Nucleo functional pack, in paticular they are: 
 PB1 user push button connected to MCU pin PC13: USER 
 PB2 reset push button connected to MCU pin NRST: RESET 
 PB3 reset push button connected to Wi-Fi module pin nRESET: WRST 

LEDs 



 Cloud-JAM board data sheet V3 

12 of 25 

 

 PB4 user push button connected to Wi-Fi module pin 13: WUSR  
 

 

.6.8 USB connector 

The USB connector act as power supply input porta at 5V dc level and also as debugger and program-
mer as refered to chapter 5.1. 

The connector is USB female 90° orientation micro B type and the part number mounted on the board is 
the FCI 10118194-0001LF. 

 
 

.6.9 Expansions connector 

Even if Cloud-JAM is mainly intended as industrialized version of FP-CLD-WATSON1 Nucleo functional 
pack, there is also an expansion connector in which there are power supply, two serial communication port 
or four general purpose I/O. 

 

Push Buttons 

USB 
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Connector is vertical type 2.54mm pitch double row Amphenol part number 95278-101A06LF 
 
Here in after the connection table. 
 

PIN NUMBER NAME DESCRIPTION 

1 I2C3_SCL/PA8 Clock line of the I2C3 of the MCU or PA8 
pin as GPIO 

2 USART6_RX/PC7 Receive line of the USART6 of the MCU 
or PC7 GPIO 

3 I2C3_SDA/PC9 Data line of the I2C3 of the MCU or PC9 
pin as GPIO 

4 USART6_TX/PC6 Transmitter line of the USART6 of the 
MCU or PC6 GPIO 

5 +3V3 3,3V power supply from Cloud-JAM. This 
is not intended as external power supply 
but only as voltage signal for polarization 
or logic circuits. Max current available for 
sourcing 25mA. 

6 GND GND reference voltage of the Cloud-JAM 

 

 
 
 

 
 
 

.7 DEVELOPMENT & DEBUG WITH CLOUD-JAM 

.7.1 System requirements 

In case Cloud-JAM is used to develop and debug applications usign ST-LINK V2 embedded debugger, 
before starting the user should:  

1. Install the preferred Integrated Development Environment (IDE).  

EXPANSION 

CONNECTOR 
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2. ST-LINK/V2-1 driver will be installed automatically. In case of problem, the user can proceed with 
manual installation of the driver, from toolchains install directory (further details are available in Section 3).  

3. Download the STM32 Nucleo firmware from the www.st.com/stm32nucleo webpage.  
4. Establish the connection with the STM32 Nucleo board, by connecting the board to the USB port of 

the PC.  
The above steps will be detailed in the coming sections 

.7.2 IDEs supporting STM32 core inside Cloud-JAM 

STMicroelectronics STM32 32-bit ARM® Cortex® -M core-based microcontrollers are supported by a 
complete range of software tools. It encompasses traditional integrated development environment IDEs with 
C/C++ compilers and debuggers from major third-parties (free versions up to 64 Kbytes of code, depending 
on third-party), completed with innovative tools from STMicroelectronics.  

Toolchains supporting all Nucleo boards are:  

 EWARM v7.10.3 or later(a)  
• 30-day evaluation edition 
• 32-Kbyte Limited QuickStart edition (16-Kbyte limitation for Cortex M0)  

 MDK-ARM v5.17 or later(a)(b)  
• MDK-Lite (32-Kbyte code size limitation)  

 TrueSTUDIO Lite v5 or later(b) 
• No limitation  

 SW4STM32 v1.5 and later(a)  
• No limitation 

Information on the toolchain version supporting the STM32 device is available on toolchain release note 
at third-party web site. 

.7.3 ST-LINK/V2-1 installation  

Exactly as per all the STM32 Nucleo boards, Cloud-JAM include an ST-LINK/V2-1 embedded debug 
tool interface. This interface needs a dedicated USB driver to be installed. This driver is available at the 
www.st.com website and supported within the following software toolchains:  

 IAR Embedded Workbench for ARM (EWARM). The toolchain is installed by default in the 
C:\Program Files\IAR Systems\Embedded Workbench x.x directory on the PC local hard disk. 
After installing EWARM, install the ST-LINK/V2-1 driver by running the ST-Link_V2_USB.exe 
from [IAR_INSTALL_DIRECTORY]\Embedded Workbench x.x\arm\drivers\ST-Link \ST-
Link_V2_USBdriver.exe.  

 Keil Microcontroller Development Kit (MDK-ARM) toolchain. The toolchain is installed by default 
in the C:\Keil directory on the PC local hard disk; the installer creates a start menu µVision5 
shortcut. When connecting the ST-LINK/V2-1 tool, the PC detects new hardware and requires 
to install the ST-LINK_V2_USB driver. The “Found New Hardware wizard” appears and guides 
the user through the steps needed to install the driver from the recommended location.  

 Atollic TrueSTUDIO STM32. The toolchain is installed by default in the C:\Program Files\Atollic 
directory on the PC local hard disk. The ST-Link_V2_USB.exe file is automatically installed 
when installing the software toolchain.  

 AC6 System Workbench for STM32 (SW4STM32). The toolchain is installed by default in the 
C:\Program Files\AC6 directory on the PC local hard disk. The ST-Link_V2_USB.exe file is au-
tomatically executed when installing the software toolchain.  

Complementary information on the firmware package content and the STM32 Nucleo requirements is 
available on the Getting started with the STM32 Nucleo board firmware package UM1726 User manual at 
the www.st.com website.  

Note: The embedded ST-LINK/V2-1 only supports SWD interface for STM32 core. 

.7.4 Firmware package  

The STM32 Nucleo examples, applications and demonstration are provided in one single .zip file. The 
extraction of the .zip file generates one folder, STM32 Nucleo_FW_VX.Y.Z, which contains the following sub-
folders: 

 Template project is a pre-configured project with empty main function to be customized by the 
user. This is helpful to start creating an application based on the peripherals drivers.  

 Example project includes toolchain projects for each peripheral example ready to be run. • Ap-
plications includes set of applications ready to be run.  

 Demonstration includes the demonstration firmware ready to be run 
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.7.5 Executing and debugging firmware using software toolchains 

The steps below can be applied to an already existing example, demonstration or template project 
available from STM32_Nucleo_FW_VX.Y.Z firmware at the www.st.com website. First of all, the user must 
read the firmware/readme.txt file, which contains the firmware description and hardware/software require-
ments. 

.7.5.1 EWARM toolchain 

The following procedure explains how to compile, link and execute an existing EWARM project.  

1. Open IAR Embedded Workbench for ARM (EWARM).  

2. In the File menu, select Open and click Workspace to display the Open Workspace dialog box. 
Browse to select either an example or demonstration or template workspace file and click Open to 
launch it in the Project window.  

3. In the Project menu, select Rebuild All to compile the project.  

4. If the project is successfully compiled, no errors and warning appears. 

To change the project settings (Include and preprocessor defines), go through the following project 
options: 

 For Include directories: Project>Options…>C/C++ compiler>  

 For pre-processor defines: Project>Options…C/C++ compiler>pre-processor> 

5. In IAR Embedded Workbench IDE, from the Project menu, select Download and Debug or, alterna-
tively, click the Download and Debug button in the toolbar, to program the Flash memory and start 
debugging. 

6. The debugger in IAR Embedded Workbench can be used to debug source code at C and assembly 
levels, set breakpoints, monitor individual variables and watch events during the code execution. To 
run the application from the Debug menu, select Go. Alternatively, click the Go button in the toolbar 
to run the application. 

.7.5.2 MDK-ARM toolchain 

1. Open Keil MDK-ARM Microcontroller Development Kit. Figure 11 shows the basic names of the 
"Keil μvision5" windows, to which this document refers. 

2. In the Project menu, select Open Project... Browse to select either an example or a demonstration 
or a template project file and click Open to launch it in the Project window.  

3. In the Project menu, select Rebuild All target files to compile the project.  
4. If the project is successfully compiled, the following window is displayed 

If user needs to change his project settings (Include and preprocessor defines), he must go through 
the project options: 

 For Include directories: Project>Options for Target > C/C++ > Include Paths 

 For pre-processor defines: Project>Options for Target > C/C++ > Preprocessor sym-
bols > Define  

5. In MDK-ARM IDE, from the Debug menu, select Start/Stop Debug Session or, alternatively, click 
the Start/Stop Debug Session button in the toolbar, to program the Flash memory and start debug-
ging. 

6. The debugger in the MDK-ARM can be used to debug source code at C and assembly levels, set 
breakpoints, monitor individual variables and watch events during the code execution. 
To run the application from the Debug menu, select Run. Alternatively, click the Run button in the 
toolbar to run the application. 

.7.5.3 TrueSTUDIO toolchain 

1. Open Atollic TrueSTUDIO for ARM product. The program launches and prompts for the workspace 
location.  

2. Browse to select a TrueSTUDIO workspace of either an example or a demonstration or a template 
workspace file and click OK to load it.  
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3. To load an existing project in the selected workspace, select Import from the File menu to display 
the Import dialog box.  

4. In the Import window, open General, select Existing Projects into Workspace and click Next. 

5. Click Select root directory and browse to the TrueSTUDIO workspace folder. 

6. In the Projects panel, select the project and click Finish.  

7. In the Project Explorer, select the project, open the Project menu, and click Build Project.  

8. If the project is successfully compiled, the following messages will be displayed on the console win-
dow  

If user needs to change the project settings (Include directories and preprocessor defines), he must 
go through Project>Properties and select C/C++ Build>Settings from the left panel: 

 For Include directories: C Compiler>Directories>Include path 

 For pre-processor defines: C Compiler>Symbols> Defined symbols  

 
9. To debug and run the application, select the project in the Project Explorer and press F11 to start a 

debug session. 
The debugger in the Atollic TrueSTUDIO can be used to debug source code at C and assembly lev-
els, set breakpoints, monitor individual variables and watch events during the code execution. To run 
the application, from the Run menu, select Resume, or alternatively click the Resume button in the 
toolbar. 

.7.5.4 SW4STM32 toolchain 

1. Open the AC6 SW4STM32 for STM32. The program launches and prompts for the workspace loca-
tion.  

2. Browse to select a SW4STM32 workspace of either an example or a demonstration or a template 
workspace file and click OK to load it.  

3. To load an existing project in the selected workspace, select Import from the File menu to display 
the Import dialog box.  

4. In the Import window, open General, select Existing Projects into Workspace and click Next Figure 
21. SW4STM32 workspace launcher dialog box 

5. Click Select root directory, browse to the SW4STM32 workspace folder.  

6. In the Projects panel, select the project and click Finish.  

7. In the Project Explorer, select the project, open the Project menu, and click Build Project.  

8. If the project is successfully compiled, the following messages display on the console window. 
To change the project settings (Include directories and preprocessor defines), simply go through Pro-
ject>Properties, select C/C++ Build>Settings from the left panel: 

 For Include directories follow the path: C Compiler>Directories>Include path  

 For pre-processor defines follow the path: C Compiler>Symbols> Defined symbols  

9. To debug and run the application, select the project in the Project Explorer and press F11 to start a 
debug session. 

The debugger in the AC6 SW4STM32 can be used to debug source code at the C and assembly 
levels, to set breakpoints, to monitor individual variables and to watch events during the code execu-
tion. To run an application select Resume, from the Run menu, or alternatively click the Resume but-
ton in the toolbar. 
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.8 GO TO PRODUCTION WITH CLOUD-JAM 
In case the application has been developed with Nucleo functional pack it’s possible to download directly the 
.bin file generated by the debug activity. 
The best way to download the firmware using the ST-LINK V2 integrated on the Cloud-JAM is to use the ST-
LINK UTILY program. 
It’s possible to download it at this web address: 

http://www.st.com/en/embedded-software/stsw-link004.html 

.8.1 ST-LINK UTILITY PC REQUIREMENTS 

The STM32 ST-LINK utility PC configuration requires as a minimum:  

 PC with USB port and Intel® Pentium® processor running a 32-bit version of one of the following Mi-
crosoft® operating systems: 

 Windows® XP 

 Windows® 7 

 Windows® 10  

 256 Mbytes of RAM • 30 Mbytes of hard disk space available 

.8.2 Installing the STM32 ST-LINK utility 

Follow these steps and the on-screen instructions to install the STM32 ST-LINK utility:  
1. Download the compressed STM32 ST-LINK utility software from the ST website. 
2. Extract the contents of the .zip file into a temporary directory.  
3. Double-click the extracted executable, setup.exe, to initiate the installation, and follow the on-

screen prompts to install the STM32 ST-LINK utility in the development environment. The docu-
mentation for the utility is located in the subdirectory \Docs where the STM32 ST-LINK utility is in-
stalled.  

 
Note:  
If an earlier version of STM32 ST-LINK utility software is already installed, follow the uninstalling instructions 
described here in after before installing the new version. 

.8.3 Uninstalling the STM32 ST-LINK utility  

Follow these steps to uninstall the STM32 ST-LINK utility: 
4. Select Start | Settings | Control Panel.  
5. Double-click on Add or Remove Programs. 
6.  Select STM32 ST-LINK utility.  
7. Click on the Remove button. 

.8.4 Cloud-JAM programming using ST-LINK UTILITY 

The STM32 ST-LINK utility can download binary .bin, Hex, or srec files into Flash or RAM. To do this, 
follow these steps: 

1. Click on Target | Program... (or Target | Program & Verify... if the user wants to verify the written 
data) to open the Open file dialog box, as shown in Figure below. If a binary file is already opened, 
go to step 3. 

 

http://www.st.com/en/embedded-software/stsw-link004.html
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2. Select a binary, Intel Hex or Motorola S-record file and click on the Open button.  
3. Specify the address from which to start programming, as shown in Figure 18: it may be a Flash or 

a RAM address. 

 
4. Select Skip Flash erase option to skip flash erase operation in case the device is already erased  
5. Select Skip Flash Protection verification to skip flash memory protection verification in case the de-

vise is not protected.  
6. Choose a verification method by selecting one of the two radio buttons:  

6.1 Verify while programming: fast on-chip verification method which compares the program 
buffer content (portion of file) with the Flash memory content.  

6.2 Verify after programming: slow but reliable verification method which reads all the pro-
grammed memory zone after the program operation ends and compares it with the file con-
tent.  

7. At last, click on the Start button to start programming:  
7.1 If Target | Program & Verify... is selected in the first step, a check is done during the pro-

gramming operation.  
7.2 If the Reset after programming box is checked, an MCU reset will be issued.  

8. Choose a verification method by selecting one of the two radio buttons:  
8.1 Verify while programming: fast on-chip verification method which compares the program 

buffer content (portion of file) with the Flash memory content.  
8.2 Verify after programming: slow but reliable verification method which reads all the pro-

grammed memory zone after the program operation ends and compares it with the file con-
tent.  

9. At last, click on the Start button to start programming:  
9.1 If Target | Program & Verify... is selected in the first step, a check is done during the pro-

gramming operation.  
9.2 If the Reset after programming box is checked, an MCU reset will be issued. 

Note:1  
The STM32F2 and STM32F4 Series supports different programming modes depending on the MCU supply 
voltage. When using ST-LINK, the MCU supply voltage should be specified in the Target | Settings Menu to 
be able to program the device with the correct mode. When using ST-LINK/V2, the supply voltage is detect-
ed automatically. If the device is read-protected, the protection will be disabled. If some Flash memory pages 
are write-protected, the protection will be disabled during programming and then recovered.  
 
Note:2  
The user can program Hex/Srec files that contains multiple segments for different target memory locations 
(Internal flash memory, external flash memory, Option bytes...). When programming the Read Out Protection 
to level 2 (debug and boot in SRAM/system Memory features are DISABLED), a message box will be dis-
played for confirmation to avoid protecting the chip by accident.  
 
Note:3  
The extra options are dedicated for programming operation on unprotected and erased devices. 
 
Note:4  
For any other detail please refer to UM0892 user manual of the STM32 ST-LINK Utility software that can be 
found here: 
http://www.st.com/content/ccc/resource/technical/document/user_manual/e6/10/d8/80/d6/1d/4a/f2/CD00262
073.pdf/files/CD00262073.pdf/jcr:content/translations/en.CD00262073.pdf 

http://www.st.com/content/ccc/resource/technical/document/user_manual/e6/10/d8/80/d6/1d/4a/f2/CD00262073.pdf/files/CD00262073.pdf/jcr:content/translations/en.CD00262073.pdf
http://www.st.com/content/ccc/resource/technical/document/user_manual/e6/10/d8/80/d6/1d/4a/f2/CD00262073.pdf/files/CD00262073.pdf/jcr:content/translations/en.CD00262073.pdf
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.9 TYPICAL APPLICATION 

.9.1 FP-CLD-WATSON1 software description 

Application software and documentation can be found at the following web address:  
http://www.st.com/content/st_com/en/products/embedded-software/mcus-embedded-software/stm32-
embedded-software/stm32-ode-function-pack-sw/fp-cld-watson1.html  
The software is based on the STM32CubeHAL hardware abstraction layer for the STM32 microcontroller. 
The package extends STM32Cube by providing a board support package (BSP) for the Wi-Fi, NFC and sen-
sor expansion boards. The drivers abstract low-level details of the hardware and allow the middleware com-
ponents and applications to access sensor data in a hardware-independent manner, to read/write infor-
mation from/to NFC/RFID tag and to access and control the Serial-to-Wi-Fi module (SPWF01SA).  
The package also includes middleware components implementing the MQ Telemetry Transport (MQTT) ap-
plication level network protocol for communication with IBM Watson IoT. MQTT is a lightweight messaging 
protocol with a small code footprint, low power and low bandwidth usage, particularly suitable for sensor data 
telemetry and implementation in embedded systems.  

A sample application to experiment connectivity with IBM Watson IoT platform is provided on top of the 
middleware stacks. Developers can use it to prototype end-to-end IoT applications, by registering the STM32 
Nucleo microsystem in the IBM Bluemix Cloud service and begin transmitting real time sensor data in a 
straightforward manner. Thanks to NFC dynamic tag, users can automatically open a trial web page provid-
ed by IBM and visualize data generated by all the sensors on the STM32 Nucleo board. 

Features  

 Complete middleware to build applications based on Wi-Fi connectivity (SPW01SA) and connect 
Cloud-JAM board with IBM Watson IoT. 

 Software interface to access the HTS221 temperature and humidity sensor, LPS22HB pressure sen-
sor, and motion sensors LSM303AGR and LSM6DSL, and to write and read the M24SR64-Y 
RFID/NFC tag. 

 Integrated MQTT protocol middleware. 

 Sample implementation available coming from X-NUCLEO-IKS01A2, X-NUCLEO-IDW01M1, and X-
NUCLEO-NFC01A1 boards plugged onto a NUCLEO-F401RE board. 

 Easy access to Watson IoT platform in IBM Watson IoT for data collection, processing and visualiza-
tion. 

 Free, user-friendly license terms. 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
IoT node with motion and environmental sensor, NFC tag, connecting to the IBM BlueMix/Watson Cloud 

via Wi-Fi. 
Thanks to NFC memory integrated, using and active host like a smartphone, when the mobile device is 

paired to the Cloud-JAM, from the board itself the web address, the serial number of the board and the keys 
to access the IBM Bluemix cloud are taken and by the smartphone it’s possible to see the real time 
measures coming from the board inside the cloud page.  

The quick start URL can be copied from the serial interface and pasted in a web browser to view the re-
al time sensor data, as shown below 

 
 
 
 
 
 

via Wi-Fi  

access point 

CLOUD 
NFC 

http://www.st.com/content/st_com/en/products/embedded-software/mcus-embedded-software/stm32-embedded-software/stm32-ode-function-pack-sw/fp-cld-watson1.html
http://www.st.com/content/st_com/en/products/embedded-software/mcus-embedded-software/stm32-embedded-software/stm32-ode-function-pack-sw/fp-cld-watson1.html
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If an NFC-enabled mobile device is available, the quick start web page can be even more easily opened 

by drawing the device near to the NFC tag, as shown below. 
 
 
 
 

 
 
 
 
 

In order to offer a visual indication of the connectivity status, the green USR on Cloud-JAM is turned ON 
once the board is connected to IBM Watson IoT; it blinks each time a sample of sensors data is transmitted. 

Cloud-JAM sends the sensors data through Wi-Fi module using an external access point. To configure 
the Wi-Fi module integrated in the Cloud-JAM (SSID and PASSWORD of the access point), there are sever-
al modes: 

 Manual configuration by the application code. 

 Automatic configuration by an external APP. 
In manual case the configuration is done using the selected development tool adding SSID and PASS-

WORD as code inside application program. 
If the configuration is done using an APP, one solution can be as follow indicated. 
 

.9.2 Access point configuration via NFC and APP 

To configure access point parameters via NFC:  
1. Download on your NFC enabled mobile phone the ST25 NFC mobile application: 

https://play.google.com/store/apps/details?id=com.st.demo (any other mobile application able to 
write NDEF parameters to NFC can also be used). 

2. Launch the ST25 NFC mobile app and press the “Compose NDEF” button. 
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3. Select Wi-Fi and enter the SSID and password for the access point. Bring your mobile phone 
close to the NFC antenna on Cloud-JAM and press the “Write to tag” button. 
 

 
 

4. Reset the Cloud-JAM board and hold down the RESET push button The application will read 
SSID and PWD from NFC and use them to connect to the AP. 

.9.3 Access point configuration using serial terminal 

1. Connect Cloud-JAM to a PC using USB cable. 
2. Configure a serial terminal with the following parameters to view log messages 

a. BAUDRATE: 460800 
b. DATA: 8 bit 
c. PARITY: none 
d. STOP: 1 bit 
e. FLOW CONTROL: none 
f. NEWLINE RX: CR+LF 
g. NEWLINE TX: CR 

3. Press RESET button on Cloud-JAM and keep pressed USER button on Cloud-JAM to force 
read of access point parameters from serial interface. 

4. Enter SSID and PASSWORD using serial interface.  

NFC ANTENNA 
AREA 
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5. Access point parameters are copied to FLASH memory; configuration is kept in memory after 
each RESET of the board. 

.10 SPECIFICATIONS 
Parameter Minimum Typical Maximum Conditions 

Power supply voltage 3,5V 5V 5,5V USB port input connector 

Input current - - 0.5A Protected by resettable 
PTC 

Operation temperature -20°C - 70°C - 

Storage temperature -40°C  85°C - 

 
Wireless standard Frequency band low Frequency band high Transmitted power 

Wi-Fi 2402 MHz 2480 MHz 11 dBm 

NFC 13.56MHz 13,56 MHz Passive NFC 

 

.11 MECHANICAL SPECIFICATIONS 

 
The measures are in mm and the view is TOP side. 
 
 
 
 

.12 HOUSING PRESCRIPTION 
Cloud-JAM is PCBA (Printed Circuit Board Assembly) system and then is not a final product, it’s neces-

sary to close the board in a specific housing or mechanical box.  
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The housing, in addition to achieve the desired functionality, musts be fireproof (in case of unexpected 
failure of the electronic board component that produce a little spark, a fire will be blocked). 

.13 PACKAGING 
 
 
 
  FRONT VIEW           REAR VIEW 
 

        
 

 
 

 
Packaging contain Cloud-JAM board only and not the USB cable or other accessories. 
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.14 UE Declaration of Conformity 
 

 
 
 
 



 Cloud-JAM board data sheet V3 

25 of 25 

 

 

.15 OPERATING ENVIRONMENT 
The operating environment excludes special environments (extreme temperatures, dust, humidity, vibrations, 
flammable gases, corrosive or explosive atmosphere, etc.). 

 

.16 DISCLAIMERS 
Products and specifications discussed herein are for reference purposes only. All information discussed 
herein is provided on an "AS IS" basis, without warranties of any kind. This document and all information dis-
cussed herein remain the sole and exclusive property of RushUp. No license of any patent, copyright, mask 
work, trademark or any other intellectual property right is granted by one party to the other party under this 
document, by implication, estoppel or other-wise.  
RushUp products are not intended for use in life support, critical care, medical, safety equipment, or similar 
applications where product failure could result in loss of life or personal or physical harm, or any military or 
defense application, or any governmental procurement to which special terms or provisions may apply. For 
updates or additional information about RushUp products, contact RushUp office. All brand names, trade-
marks and registered trademarks belong to their respective owners. 
 


